CVE-2019-19061

NameCVE-2019-19061
DescriptionA memory leak in the adis_update_scan_mode_burst() function in drivers/iio/imu/adis_buffer.c in the Linux kernel before 5.3.9 allows attackers to cause a denial of service (memory consumption), aka CID-9c0530e898f3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.76-1vulnerable
stretch4.9.189-3vulnerable
stretch (security)4.9.189-3+deb9u2vulnerable
buster4.19.67-2+deb10u1vulnerable
buster (security)4.19.67-2+deb10u2vulnerable
bullseye5.3.9-3fixed
sid5.3.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.3.9-1unimportant

Notes

https://git.kernel.org/linus/9c0530e898f384c5d279bfcebd8bb17af1105873

Search for package or bug name: Reporting problems