CVE-2019-19067

NameCVE-2019-19067
Description** DISPUTED ** Four memory leaks in the acp_hw_init() function in drivers/gpu/drm/amd/amdgpu/amdgpu_acp.c in the Linux kernel before 5.3.8 allow attackers to cause a denial of service (memory consumption) by triggering mfd_add_hotplug_devices() or pm_genpd_add_device() failures, aka CID-57be09c6e874. NOTE: third parties dispute the relevance of this because the attacker must already have privileges for module loading.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.76-1vulnerable
stretch4.9.189-3vulnerable
stretch (security)4.9.189-3+deb9u2vulnerable
buster4.19.67-2+deb10u1vulnerable
buster (security)4.19.67-2+deb10u2vulnerable
bullseye5.3.9-3fixed
sid5.3.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.3.9-1unimportant

Notes

https://git.kernel.org/linus/57be09c6e8747bf48704136d9e3f92bfb93f5725

Search for package or bug name: Reporting problems