CVE-2019-19204

NameCVE-2019-19204
DescriptionAn issue was discovered in Oniguruma 6.x before 6.9.4_rc2. In the function fetch_interval_quantifier (formerly known as fetch_range_quantifier) in regparse.c, PFETCH is called without checking PEND. This leads to a heap-based buffer over-read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2020-1
NVD severityhigh
Debian Bugs945313

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libonig (PTS)jessie5.9.5-3.2+deb8u1vulnerable
jessie (security)5.9.5-3.2+deb8u4fixed
stretch6.1.3-2vulnerable
buster6.9.1-1vulnerable
bullseye, sid6.9.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libonigsource(unstable)(unfixed)low945313
libonigsourcejessie5.9.5-3.2+deb8u4DLA-2020-1

Notes

[buster] - libonig <no-dsa> (Minor issue)
[stretch] - libonig <no-dsa> (Minor issue)
https://github.com/kkos/oniguruma/issues/162
https://github.com/kkos/oniguruma/commit/6eb4aca6a7f2f60f473580576d86686ed6a6ebec (v6.9.4_rc2)
Only exploitable with attacker-provided pattern

Search for package or bug name: Reporting problems