CVE-2019-19246

NameCVE-2019-19246
DescriptionOniguruma through 6.9.3, as used in PHP 7.3.x and other products, has a heap-based buffer over-read in str_lower_case_match in regexec.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2020-1
Debian Bugs946344

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libonig (PTS)jessie5.9.5-3.2+deb8u1vulnerable
jessie (security)5.9.5-3.2+deb8u4fixed
stretch6.1.3-2vulnerable
buster6.9.1-1vulnerable
bullseye, sid6.9.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libonigsource(unstable)(unfixed)low946344
libonigsourcejessie5.9.5-3.2+deb8u4DLA-2020-1

Notes

[buster] - libonig <no-dsa> (Minor issue)
[stretch] - libonig <no-dsa> (Minor issue)
https://bugs.php.net/bug.php?id=78559
https://github.com/kkos/oniguruma/commit/d3e402928b6eb3327f8f7d59a9edfa622fec557b

Search for package or bug name: Reporting problems