CVE-2019-19344

NameCVE-2019-19344
DescriptionThere is a use-after-free issue in all samba 4.9.x versions before 4.9.18, all samba 4.10.x versions before 4.10.12 and all samba 4.11.x versions before 4.11.5, essentially due to a call to realloc() while other local variables still point at the original buffer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs950499

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)stretch2:4.5.16+dfsg-1+deb9u2fixed
stretch (security)2:4.5.16+dfsg-1+deb9u4fixed
buster2:4.9.5+dfsg-5vulnerable
buster (security)2:4.9.5+dfsg-5+deb10u2vulnerable
bullseye2:4.13.5+dfsg-2fixed
bullseye (security)2:4.13.13+dfsg-1~deb11u2fixed
bookworm, sid2:4.13.14+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcejessie(not affected)
sambasourcestretch(not affected)
sambasource(unstable)2:4.11.5+dfsg-1950499

Notes

[buster] - samba <no-dsa> (Minor issue)
[stretch] - samba <not-affected> (Only affects Samba 4.9 onwards)
[jessie] - samba <not-affected> (Only affects Samba 4.9 onwards)
https://www.samba.org/samba/security/CVE-2019-19344.html

Search for package or bug name: Reporting problems