CVE-2019-19450

NameCVE-2019-19450
Descriptionparaparser in ReportLab before 3.5.31 allows remote code execution because start_unichar in paraparser.py evaluates untrusted user input in a unichar element in a crafted XML document with '<unichar code="' followed by arbitrary Python code, a similar issue to CVE-2019-17626.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3590-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-reportlab (PTS)buster3.5.13-1+deb10u1vulnerable
buster (security)3.5.13-1+deb10u2fixed
bullseye3.5.59-2fixed
bookworm3.6.12-1fixed
trixie4.1.0-1fixed
sid4.1.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-reportlabsourcebuster3.5.13-1+deb10u2DLA-3590-1
python-reportlabsource(unstable)3.5.31-1

Notes

https://github.com/MrBitBucket/reportlab-mirror/blob/master/CHANGES.md#release-353115102019
Fixed by: https://hg.reportlab.com/hg-public/reportlab/rev/b117091a73c2

Search for package or bug name: Reporting problems