CVE-2019-19481

NameCVE-2019-19481
DescriptionAn issue was discovered in OpenSC through 0.19.0 and 0.20.x through 0.20.0-rc3. libopensc/card-cac1.c mishandles buffer limits for CAC certificates.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opensc (PTS)jessie0.14.0-2fixed
jessie (security)0.16.0-3+deb8u1fixed
stretch0.16.0-3+deb9u1fixed
buster0.19.0-1fixed
bullseye, sid0.19.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openscsource(unstable)0.19.0~rc1-1
openscsourcejessie(not affected)
openscsourcestretch(not affected)

Notes

[stretch] - opensc <not-affected> (Vulnerable code not present)
[jessie] - opensc <not-affected> (Vulnerable code not present)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=18618
CAC support added in: https://github.com/OpenSC/OpenSC/commit/777e2a3751e3f6d53f056c98e9e20e42af674fb1 (0.17.0-rc1)
Drop support of CAC1: https://github.com/OpenSC/OpenSC/commit/2190bb927c739852266481d6517aaf3a07b52526 (0.19.0-rc1)
Restored minimal CAC1 driver support: https://github.com/OpenSC/OpenSC/commit/e2b1fb81e0e1339eebaa36fb90635e03f69d4da3 (0.20.0-rc1)
https://github.com/OpenSC/OpenSC/commit/b75c002cfb1fd61cd20ec938ff4937d7b1a94278
Mark 0.19.0~rc1 based version as fixed which removed the affected code, which
later was re-introduced upstream in 0.20.0~rc1 again.

Search for package or bug name: Reporting problems