CVE-2019-19601

NameCVE-2019-19601
DescriptionOpenDetex 2.8.5 has a Buffer Overflow in TexOpen in detex.l because of an incorrect sprintf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs949630

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
texlive-bin (PTS)jessie2014.20140926.35254-6vulnerable
jessie (security)2014.20140926.35254-6+deb8u1vulnerable
stretch (security), stretch2016.20160513.41080.dfsg-2+deb9u1vulnerable
buster2018.20181218.49446-1vulnerable
bullseye, sid2019.20190605.51237-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
texlive-binsource(unstable)(unfixed)unimportant949630

Notes

https://github.com/pkubowicz/opendetex/issues/60
Debian builds using the kpathsea codepaths.

Search for package or bug name: Reporting problems