CVE-2019-19602

NameCVE-2019-19602
Descriptionfpregs_state_valid in arch/x86/include/asm/fpu/internal.h in the Linux kernel before 5.4.2, when GCC 9 is used, allows context-dependent attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact because of incorrect fpu_fpregs_owner_ctx caching, as demonstrated by mishandling of signal-based non-cooperative preemption in Go 1.14 prereleases on amd64, aka CID-59c4bd853abc.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.81-1fixed
stretch4.9.210-1fixed
stretch (security)4.9.189-3+deb9u2fixed
buster4.19.98-1fixed
buster (security)4.19.67-2+deb10u2fixed
bullseye5.4.19-1fixed
sid5.5.13-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.3.15-1
linuxsourcebuster(not affected)
linuxsourcejessie(not affected)
linuxsourcestretch(not affected)

Notes

[buster] - linux <not-affected> (Vulnerable code introduced later)
[stretch] - linux <not-affected> (Vulnerable code introduced later)
[jessie] - linux <not-affected> (Vulnerable code introduced later)
https://git.kernel.org/linus/59c4bd853abcea95eccc167a7d7fd5f1a5f47b98

Search for package or bug name: Reporting problems