CVE-2019-19721

NameCVE-2019-19721
DescriptionAn off-by-one error in the DecodeBlock function in codec/sdl_image.c in VideoLAN VLC media player before 3.0.9 allows remote attackers to cause a denial of service (memory corruption) via a crafted image file. NOTE: this may be related to the SDL_Image product.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4671-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)jessie (security), jessie2.2.7-1~deb8u1vulnerable
stretch3.0.8-0+deb9u1vulnerable
stretch (security)3.0.10-0+deb9u1fixed
buster, buster (security)3.0.10-0+deb10u1fixed
bullseye, sid3.0.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)3.0.9.2-1
vlcsourcebuster3.0.10-0+deb10u1DSA-4671-1
vlcsourcejessie(unfixed)end-of-life
vlcsourcestretch3.0.10-0+deb9u1DSA-4671-1

Notes

[jessie] - vlc <end-of-life> (https://lists.debian.org/debian-security-announce/2018/msg00130.html)
https://git.videolan.org/?p=vlc/vlc-3.0.git;a=commit;h=72afe7ebd8305bf4f5360293b8621cde52ec506b (3.0.9)

Search for package or bug name: Reporting problems