CVE-2019-19746

NameCVE-2019-19746
Descriptionmake_arrow in arrow.c in Xfig fig2dev 3.2.7b allows a segmentation fault and out-of-bounds write because of an integer overflow via a large arrow type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs946628

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fig2dev (PTS)stretch1:3.2.6a-2+deb9u2vulnerable
buster1:3.2.7a-5+deb10u1vulnerable
bullseye, sid1:3.2.7b-3fixed
transfig (PTS)jessie1:3.2.5.e-4+deb8u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fig2devsource(unstable)1:3.2.7b-3unimportant946628
transfigsource(unstable)(unfixed)unimportant

Notes

https://sourceforge.net/p/mcj/tickets/57/
https://sourceforge.net/p/mcj/fig2dev/ci/3065abc7b4f740ed6532322843531317de782a26/

Search for package or bug name: Reporting problems