CVE-2019-19911

NameCVE-2019-19911
DescriptionThere is a DoS vulnerability in Pillow before 6.2.2 caused by FpxImagePlugin.py calling the range function on an unvalidated 32-bit integer if the number of bands is large. On Windows running 32-bit Python, this results in an OverflowError or MemoryError due to the 2 GB limit. However, on Linux running 64-bit Python this results in the process being terminated by the OOM killer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2057-1, DSA-4631-1
NVD severitymedium
Debian Bugs948224

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)jessie2.6.1-2+deb8u3vulnerable
jessie (security)2.6.1-2+deb8u4fixed
stretch4.0.0-4vulnerable
stretch (security)4.0.0-4+deb9u1fixed
buster5.4.1-2vulnerable
buster (security)5.4.1-2+deb10u1fixed
bullseye6.2.1-2vulnerable
sid7.0.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)7.0.0-1948224
pillowsourcebuster5.4.1-2+deb10u1DSA-4631-1
pillowsourcejessie2.6.1-2+deb8u4DLA-2057-1
pillowsourcestretch4.0.0-4+deb9u1DSA-4631-1

Notes

https://github.com/python-pillow/Pillow/commit/774e53bb132461d8d5ebefec1162e29ec0ebc63d (6.2.2)

Search for package or bug name: Reporting problems