CVE-2019-19921

NameCVE-2019-19921
Descriptionrunc through 1.0.0-rc9 has Incorrect Access Control leading to Escalation of Privileges, related to libcontainer/rootfs_linux.go. To exploit this, an attacker must be able to spawn two containers with custom volume-mount configurations, and be able to run custom images. (This vulnerability does not affect Docker due to an implementation detail that happens to block the attack.)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
runc (PTS)stretch0.1.1+dfsg1-2+deb9u1vulnerable
stretch (security)0.1.1+dfsg1-2+deb9u2vulnerable
buster1.0.0~rc6+dfsg1-3vulnerable
bullseye, sid1.0.0~rc92+dfsg1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
runcsource(unstable)1.0.0~rc10+dfsg1-1

Notes

[buster] - runc <no-dsa> (Minor issue)
[stretch] - runc <no-dsa> (Minor issue)
https://github.com/opencontainers/runc/issues/2197
https://github.com/opencontainers/runc/pull/2190

Search for package or bug name: Reporting problems