CVE-2019-19926

NameCVE-2019-19926
DescriptionmultiSelect in select.c in SQLite 3.30.1 mishandles certain errors during parsing, as demonstrated by errors from sqlite3WindowRewrite() calls. NOTE: this vulnerability exists because of an incomplete fix for CVE-2019-19880.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4638-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)stretch (security), stretch73.0.3683.75-1~deb9u1vulnerable
buster, buster (security)83.0.4103.116-1~deb10u3fixed
bullseye, sid83.0.4103.116-3.1fixed
sqlite3 (PTS)stretch3.16.2-5+deb9u1fixed
stretch (security)3.16.2-5+deb9u2fixed
buster3.27.2-3fixed
bullseye, sid3.33.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsourcestretch(unfixed)end-of-life
chromiumsourcebuster80.0.3987.132-1~deb10u1DSA-4638-1
chromiumsource(unstable)80.0.3987.106-1
sqlite3source(unstable)(not affected)

Notes

- sqlite3 <not-affected> (Incomplete fix for CVE-2019-19880 not applied)
https://github.com/sqlite/sqlite/commit/8428b3b437569338a9d1e10c4cd8154acbe33089
[stretch] - chromium <end-of-life> (see DSA 4562)

Search for package or bug name: Reporting problems