CVE-2019-19966

NameCVE-2019-19966
DescriptionIn the Linux kernel before 5.1.6, there is a use-after-free in cpia2_exit() in drivers/media/usb/cpia2/cpia2_v4l.c that will cause denial of service, aka CID-dea37a972655.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2068-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.210-1+deb9u1fixed
buster4.19.146-1fixed
buster (security)4.19.152-1fixed
bullseye, sid5.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie3.16.81-1DLA-2068-1
linuxsourcestretch4.9.184-1
linuxsourcebuster4.19.67-1
linuxsource(unstable)5.2.6-1

Notes

https://git.kernel.org/linus/dea37a97265588da604c6ba80160a287b72c7bfd

Search for package or bug name: Reporting problems