CVE-2019-20041

NameCVE-2019-20041
Descriptionwp_kses_bad_protocol in wp-includes/kses.php in WordPress before 5.3.1 mishandles the HTML5 colon named entity, allowing attackers to bypass input sanitization, as demonstrated by the javascript: substring.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2067-1, DSA-4599-1
NVD severityhigh
Debian Bugs946905

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17vulnerable
jessie (security)4.1.29+dfsg-0+deb8u1fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u5vulnerable
buster5.0.4+dfsg1-1vulnerable
buster (security)5.0.4+dfsg1-1+deb10u1fixed
bullseye, sid5.3.2+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)5.3.2+dfsg1-1946905
wordpresssourcebuster5.0.4+dfsg1-1+deb10u1DSA-4599-1
wordpresssourcejessie4.1.29+dfsg-0+deb8u1DLA-2067-1

Notes

https://github.com/WordPress/wordpress-develop/commit/b1975463dd995da19bb40d3fa0786498717e3c53
https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/

Search for package or bug name: Reporting problems