CVE-2019-20170

NameCVE-2019-20170
DescriptionAn issue was discovered in GPAC version 0.8.0 and 0.9.0-development-20191109. There is an invalid pointer dereference in the function GF_IPMPX_AUTH_Delete() in odf/ipmpx_code.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2072-1
Debian Bugs972053, 994746

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ccextractor (PTS)buster0.87+ds1-1vulnerable
bullseye0.88+ds1-1vulnerable
sid0.94+ds1-1fixed
gpac (PTS)buster0.5.2-426-gc5ad4e4+dfsg5-5vulnerable
bullseye (security), bullseye1.0.1+dfsg1-4+deb11u1fixed
bookworm, sid2.0.0+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ccextractorsource(unstable)0.93+ds2-1994746
gpacsourcejessie0.5.0+svn5324~dfsg1-1+deb8u5DLA-2072-1
gpacsource(unstable)1.0.1+dfsg1-2972053

Notes

[buster] - gpac <no-dsa> (Minor issue)
[stretch] - gpac <no-dsa> (Minor issue)
[bullseye] - ccextractor <no-dsa> (Minor issue)
[buster] - ccextractor <no-dsa> (Minor issue)
https://github.com/gpac/gpac/issues/1328
https://github.com/gpac/gpac/commit/16856430287cc10f495eb241910b4dc45b193e03

Search for package or bug name: Reporting problems