CVE-2019-20326

NameCVE-2019-20326
DescriptionA heap-based buffer overflow in _cairo_image_surface_create_from_jpeg() in extensions/cairo_io/cairo-image-surface-jpeg.c in GNOME gThumb before 3.8.3 and Linux Mint Pix before 2.4.5 allows attackers to cause a crash and potentially execute arbitrary code via a crafted JPEG file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2066-1
NVD severitymedium
Debian Bugs948197

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gthumb (PTS)stretch3:3.4.4.1-5+deb9u1vulnerable
buster3:3.6.2-4vulnerable
bullseye, sid3:3.8.0-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gthumbsource(unstable)(unfixed)948197
gthumbsourcejessie3:3.3.1-2.1+deb8u2DLA-2066-1

Notes

[buster] - gthumb <no-dsa> (Minor issue)
[stretch] - gthumb <no-dsa> (Minor issue)
https://gitlab.gnome.org/GNOME/gthumb/commit/14860321ce3235d420498c4f81f21003d1fb78f4 (3.8.3)
https://gitlab.gnome.org/GNOME/gthumb/commit/4faa5ce2358812d23a1147953ee76f59631590ad (master)

Search for package or bug name: Reporting problems