CVE-2019-20330

NameCVE-2019-20330
DescriptionFasterXML jackson-databind 2.x before 2.9.10.2 lacks certain net.sf.ehcache blocking.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2111-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackson-databind (PTS)stretch (security), stretch2.8.6-1+deb9u6vulnerable
buster, buster (security)2.9.8-3+deb10u1vulnerable
bullseye, sid2.10.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackson-databindsource(unstable)2.10.1-1
jackson-databindsourcejessie2.4.2-2+deb8u11DLA-2111-1

Notes

[buster] - jackson-databind <no-dsa> (Minor issue; can be fixed via a point release)
[stretch] - jackson-databind <no-dsa> (Minor issue; can be fixed via a point release)
https://github.com/FasterXML/jackson-databind/issues/2526
https://github.com/FasterXML/jackson-databind/commit/fc4214a883dc087070f25da738ef0d49c2f3387e

Search for package or bug name: Reporting problems