CVE-2019-20386

NameCVE-2019-20386
DescriptionAn issue was discovered in button_open in login/logind-button.c in systemd before 243. When executing the udevadm trigger command, a memory leak may occur.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
systemd (PTS)buster, buster (security)241-7~deb10u8vulnerable
bullseye247.3-7+deb11u1fixed
bookworm, sid251.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
systemdsource(unstable)243-5unimportant

Notes

https://github.com/systemd/systemd/commit/b2774a3ae692113e1f47a336a6c09bac9cfb49ad
Negligible security impact, requires root or physical access to plug in a device,
at which point you can just as well DoS the computer with a hammer instead

Search for package or bug name: Reporting problems