DescriptionPyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pyyaml (PTS)buster3.13-2fixed
bookworm, sid6.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pyyamlsourcejessie(not affected)
pyyamlsourcestretch(not affected)
pyyamlsourcebuster(not affected)


[buster] - pyyaml <not-affected> (Vulnerability introduced in 5.1)
[stretch] - pyyaml <not-affected> (Vulnerability introduced in 5.1)
[jessie] - pyyaml <not-affected> (Vulnerability introduced in 5.1)
CVE exists due to an incomplete fix for CVE-2017-18342.

Search for package or bug name: Reporting problems