CVE-2019-20477

NameCVE-2019-20477
DescriptionPyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pyyaml (PTS)stretch3.12-1fixed
buster3.13-2fixed
bullseye, sid5.3.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pyyamlsourcejessie(not affected)
pyyamlsourcestretch(not affected)
pyyamlsourcebuster(not affected)
pyyamlsource(unstable)5.2-1unimportant

Notes

[buster] - pyyaml <not-affected> (Vulnerability introduced in 5.1)
[stretch] - pyyaml <not-affected> (Vulnerability introduced in 5.1)
[jessie] - pyyaml <not-affected> (Vulnerability introduced in 5.1)
CVE exists due to an incomplete fix for CVE-2017-18342.

Search for package or bug name: Reporting problems