CVE-2019-20806

NameCVE-2019-20806
DescriptionAn issue was discovered in the Linux kernel before 5.2. There is a NULL pointer dereference in tw5864_handle_frame() in drivers/media/pci/tw5864/tw5864-video.c, which may cause denial of service, aka CID-2e7682ebfc75.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2242-1, DSA-4698-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.210-1vulnerable
stretch (security)4.9.210-1+deb9u1fixed
buster4.19.118-2fixed
buster (security)4.19.118-2+deb10u1fixed
bullseye, sid5.7.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.2.6-1
linuxsourcebuster4.19.118-1
linuxsourcejessie(not affected)
linuxsourcestretch4.9.210-1+deb9u1DSA-4698-1
linux-4.9sourcejessie4.9.210-1+deb9u1~deb8u1DLA-2242-1

Notes

[jessie] - linux <not-affected> (Vulnerable code introduced later)
https://git.kernel.org/linus/2e7682ebfc750177a4944eeb56e97a3f05734528

Search for package or bug name: Reporting problems