CVE-2019-20807

NameCVE-2019-20807
DescriptionIn Vim before 8.1.0881, users can circumvent the rvim restricted mode and execute arbitrary OS commands via scripting interfaces (e.g., Python, Ruby, or Lua).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch (security), stretch2:8.0.0197-4+deb9u3vulnerable
buster2:8.1.0875-5vulnerable
bullseye, sid2:8.2.0716-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:8.1.2136-1

Notes

[buster] - vim <no-dsa> (Minor issue)
[stretch] - vim <no-dsa> (Minor issue)
[jessie] - vim <no-dsa> (Minor issue)
https://github.com/vim/vim/commit/8c62a08faf89663e5633dc5036cd8695c80f1075

Search for package or bug name: Reporting problems