CVE-2019-20838

NameCVE-2019-20838
Descriptionlibpcre in PCRE before 8.43 allows a subject buffer over-read in JIT when UTF is disabled, and \X or \R has more than one fixed quantifier, a related issue to CVE-2019-20454.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)stretch2:8.39-3vulnerable
buster2:8.39-12vulnerable
bullseye, sid2:8.39-13vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3source(unstable)(unfixed)unimportant

Notes

Fixed by: https://vcs.pcre.org/pcre?view=revision&revision=1740 (8.43)
Only an issue when UTF support disabled

Search for package or bug name: Reporting problems