CVE-2019-25010

NameCVE-2019-25010
DescriptionAn issue was discovered in the failure crate through 2019-11-13 for Rust. Type confusion can occur when __private_get_type_id__ is overridden.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-failure (PTS)buster0.1.5-1vulnerable
bullseye, sid0.1.7-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-failuresource(unstable)(unfixed)

Notes

[bullseye] - rust-failure <no-dsa> (Minor issue, unmaintained/deprecated upstream)
[buster] - rust-failure <no-dsa> (Minor issue, unmaintained/deprecated upstream)
https://rustsec.org/advisories/RUSTSEC-2019-0036.html

Search for package or bug name: Reporting problems