CVE-2019-25013

NameCVE-2019-25013
DescriptionThe iconv feature in the GNU C Library (aka glibc or libc6) through 2.32, when processing invalid multi-byte input sequences in the EUC-KR encoding, may have a buffer over-read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs979273

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)stretch2.24-11+deb9u4vulnerable
stretch (security)2.24-11+deb9u1vulnerable
buster2.28-10vulnerable
bullseye, sid2.31-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glibcsource(unstable)2.31-9979273

Notes

[buster] - glibc <no-dsa> (Minor issue)
[stretch] - glibc <postponed> (Minor issue; can be fixed in next update)
https://sourceware.org/bugzilla/show_bug.cgi?id=24973
Fixed by: https://sourceware.org/git/?p=glibc.git;a=commit;h=ee7a3144c9922808181009b7b3e50e852fb4999b

Search for package or bug name: Reporting problems