CVE-2019-2503

NameCVE-2019-2503
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Connection Handling). Supported versions that are affected are 5.6.42 and prior, 5.7.24 and prior and 8.0.13 and prior. Difficult to exploit vulnerability allows low privileged attacker with access to the physical communication segment attached to the hardware where the MySQL Server executes to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all MySQL Server accessible data and unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 6.4 (Confidentiality and Availability impacts). CVSS Vector: (CVSS:3.0/AV:A/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1570-1, DSA-4341-1
NVD severitylow (attack range: remote)
Debian Bugs919817

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.32-0+deb8u1vulnerable
jessie (security)10.0.38-0+deb8u1fixed
mariadb-10.1 (PTS)stretch10.1.38-0+deb9u1fixed
stretch (security)10.1.37-0+deb9u1fixed
mysql-5.7 (PTS)sid5.7.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)low
mariadb-10.0sourcejessie10.0.37-0+deb8u1lowDLA-1570-1
mariadb-10.1sourcestretch10.1.37-0+deb9u1lowDSA-4341-1
mysql-5.7source(unstable)5.7.25-1low919817

Notes

Fixed in MariaDB: 10.0.37

Search for package or bug name: Reporting problems