CVE-2019-25037

NameCVE-2019-25037
DescriptionUnbound before 1.9.5 allows an assertion failure and denial of service in dname_pkt_copy via an invalid packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2652-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unbound (PTS)stretch1.6.0-3+deb9u2vulnerable
buster, buster (security)1.9.0-2+deb10u2vulnerable
bullseye, sid1.13.1-1fixed
unbound1.9 (PTS)stretch (security)1.9.0-2+deb10u2~deb9u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unboundsourcestretch(unfixed)end-of-life
unboundsource(unstable)1.9.6-1
unbound1.9sourcestretch1.9.0-2+deb10u2~deb9u2DLA-2652-1

Notes

[stretch] - unbound <end-of-life> (No longer supported, see DSA 4694)
https://github.com/NLnetLabs/unbound/commit/d2eb78e871153f22332d30c6647f3815148f21e5

Search for package or bug name: Reporting problems