CVE-2019-25042

NameCVE-2019-25042
DescriptionUnbound before 1.9.5 allows an out-of-bounds write via a compressed name in rdata_copy. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2652-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unbound (PTS)buster1.9.0-2+deb10u2vulnerable
buster (security)1.9.0-2+deb10u4vulnerable
bullseye1.13.1-1+deb11u1fixed
bullseye (security)1.13.1-1+deb11u2fixed
bookworm1.17.1-2+deb12u1fixed
bookworm (security)1.17.1-2+deb12u2fixed
trixie1.19.1-1fixed
sid1.19.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unboundsourcestretch(unfixed)end-of-life
unboundsource(unstable)1.9.6-1unimportant
unbound1.9sourcestretch1.9.0-2+deb10u2~deb9u2DLA-2652-1

Notes

[stretch] - unbound <end-of-life> (No longer supported, see DSA 4694)
https://github.com/NLnetLabs/unbound/commit/6c3a0b54ed8ace93d5b5ca7b8078dc87e75cd640
Not deemed an exploitable vulnerability by upstream

Search for package or bug name: Reporting problems