CVE-2019-25043

NameCVE-2019-25043
DescriptionModSecurity 3.x before 3.0.4 mishandles key-value pair parsing, as demonstrated by a "string index out of range" error and worker-process crash for a "Cookie: =abc" header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
modsecurity (PTS)buster, buster (security)3.0.3-1+deb10u2vulnerable
bullseye3.0.4-2fixed
bookworm, sid3.0.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
modsecuritysource(unstable)3.0.4-1

Notes

[buster] - modsecurity <no-dsa> (Minor issue)
https://github.com/SpiderLabs/ModSecurity/issues/2566
https://github.com/SpiderLabs/ModSecurity/commit/9cac167fafd180902c2aa5dc6141aae874127199

Search for package or bug name: Reporting problems