CVE-2019-25052

NameCVE-2019-25052
DescriptionIn Linaro OP-TEE before 3.7.0, by using inconsistent or malformed data, it is possible to call update and final cryptographic functions directly, causing a crash that could leak sensitive information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
optee-os (PTS)trixie, sid4.1.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
optee-ossource(unstable)(not affected)

Notes

- optee-os <not-affected> (Fixed before initial upload)
https://github.com/OP-TEE/optee_os/security/advisories/GHSA-pgwr-qmgh-vhmf
https://github.com/OP-TEE/optee_os/commit/34a08bec755670ea0490cb53bbc68058cafc69b6 (3.7.0-rc1)

Search for package or bug name: Reporting problems