CVE-2019-2537

NameCVE-2019-2537
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DDL). Supported versions that are affected are 5.6.42 and prior, 5.7.24 and prior and 8.0.13 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1655-1
NVD severitymedium
Debian Bugs919817, 920933

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.32-0+deb8u1vulnerable
jessie (security)10.0.38-0+deb8u1fixed
mariadb-10.1 (PTS)stretch10.1.41-0+deb9u1fixed
stretch (security)10.1.37-0+deb9u1vulnerable
mariadb-10.3 (PTS)buster1:10.3.18-0+deb10u1fixed
bullseye, sid1:10.3.20-1fixed
mysql-5.7 (PTS)sid5.7.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)
mariadb-10.0sourcejessie10.0.38-0+deb8u1DLA-1655-1
mariadb-10.1source(unstable)(unfixed)
mariadb-10.1sourcestretch10.1.38-0+deb9u1
mariadb-10.3source(unstable)1:10.3.13-1920933
mysql-5.7source(unstable)5.7.25-1919817

Notes

Fixed in MariaDB: 10.3.13, 10.1.38, 10.0.38

Search for package or bug name: Reporting problems