CVE-2019-2805

NameCVE-2019-2805
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Parser). Supported versions that are affected are 5.6.44 and prior, 5.7.26 and prior and 8.0.16 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 6.5 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs932340

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.1 (PTS)stretch10.1.38-0+deb9u1vulnerable
stretch (security)10.1.37-0+deb9u1vulnerable
mariadb-10.3 (PTS)bullseye, buster1:10.3.15-1vulnerable
sid1:10.3.17-1fixed
mysql-5.7 (PTS)sid5.7.26-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.1source(unstable)(unfixed)medium
mariadb-10.3source(unstable)1:10.3.17-1medium
mysql-5.7source(unstable)(unfixed)medium932340

Notes

[buster] - mariadb-10.3 <no-dsa> (Minor issue; can be fixed in point release)
Fixed in MariaDB: 10.3.17, 10.1.41
https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html#AppendixMSQL

Search for package or bug name: Reporting problems