CVE-2019-2938

NameCVE-2019-2938
DescriptionVulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.7.27 and prior and 8.0.17 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs942443

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.3 (PTS)buster1:10.3.34-0+deb10u1fixed
buster (security)1:10.3.25-0+deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.3sourcebuster1:10.3.22-0+deb10u1
mariadb-10.3source(unstable)1:10.3.19-1
mysql-5.7source(unstable)(unfixed)942443

Notes

https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html#AppendixMSQL

Search for package or bug name: Reporting problems