CVE-2019-3459

NameCVE-2019-3459
DescriptionA heap address information leak while using L2CAP_GET_CONF_OPT was discovered in the Linux kernel before 5.1-rc1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1771-1, DLA-1799-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.68-2fixed
stretch4.9.168-1fixed
stretch (security)4.9.168-1+deb9u3fixed
buster, sid4.19.37-3fixed
linux-4.9 (PTS)jessie (security)4.9.168-1+deb9u3~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.19.37-1low
linuxsourcejessie3.16.68-1lowDLA-1799-1
linuxsourcestretch4.9.168-1low
linux-4.9sourcejessie4.9.168-1~deb8u1lowDLA-1771-1

Notes

https://lore.kernel.org/linux-bluetooth/20190110062833.GA15047@kroah.com/
https://git.kernel.org/linus/7c9cbd0b5e38a1672fcd137894ace3b042dfbf69

Search for package or bug name: Reporting problems