CVE-2019-3812

NameCVE-2019-3812
DescriptionQEMU, through version 2.10 and through version 3.1.0, is vulnerable to an out-of-bounds read of up to 128 bytes in the hw/i2c/i2c-ddc.c:i2c_ddc() function. A local attacker with permission to execute i2c commands could exploit this to read stack memory of the qemu process on the host.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4454-1
NVD severitylow (attack range: local)
Debian Bugs922635

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6fixed
jessie (security)1:2.1+dfsg-12+deb8u11fixed
stretch1:2.8+dfsg-6+deb9u5vulnerable
stretch (security)1:2.8+dfsg-6+deb9u8fixed
buster1:3.1+dfsg-8~deb10u1fixed
bullseye, sid1:3.1+dfsg-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:3.1+dfsg-5low922635
qemusourcejessie(not affected)
qemusourcestretch1:2.8+dfsg-6+deb9u6lowDSA-4454-1
qemu-kvmsource(unstable)(unfixed)low

Notes

[jessie] - qemu <not-affected> (vulnerable code introduced later)
https://git.qemu.org/?p=qemu.git;a=commit;h=b05b267840515730dbf6753495d5b7bd8b04ad1c
vulnerable code not present prior 2.6.50, introduced in
https://git.qemu.org/?p=qemu.git;a=commit;h=78c71af8049c40657b646d9dd722867fa15c0f1b

Search for package or bug name: Reporting problems