CVE-2019-3813

NameCVE-2019-3813
DescriptionSpice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1649-1, DSA-4375-1
NVD severitymedium (attack range: remote)
Debian Bugs920762

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spice (PTS)jessie0.12.5-1+deb8u5vulnerable
jessie (security)0.12.5-1+deb8u7fixed
stretch (security), stretch0.12.8-2.1+deb9u3fixed
bullseye, sid, buster0.14.0-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spicesource(unstable)0.14.0-1.3medium920762
spicesourcejessie0.12.5-1+deb8u7mediumDLA-1649-1
spicesourcestretch0.12.8-2.1+deb9u3mediumDSA-4375-1

Notes

https://www.openwall.com/lists/oss-security/2019/01/28/2
https://bugzilla.redhat.com/show_bug.cgi?id=1665371

Search for package or bug name: Reporting problems