CVE-2019-3814

NameCVE-2019-3814
DescriptionIt was discovered that Dovecot before versions 2.2.36.1 and 2.3.4.1 incorrectly handled client certificates. A remote attacker in possession of a valid certificate with an empty username field could possibly use this issue to impersonate other users.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1667-1, DSA-4385-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dovecot (PTS)jessie1:2.2.13-12~deb8u4vulnerable
jessie (security)1:2.2.13-12~deb8u6fixed
stretch1:2.2.27-3+deb9u2vulnerable
stretch (security)1:2.2.27-3+deb9u4fixed
buster, sid1:2.3.4.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dovecotsource(unstable)1:2.3.4.1-1medium
dovecotsourcejessie1:2.2.13-12~deb8u5mediumDLA-1667-1
dovecotsourcestretch1:2.2.27-3+deb9u3mediumDSA-4385-1

Notes

https://www.openwall.com/lists/oss-security/2019/02/05/1

Search for package or bug name: Reporting problems