CVE-2019-3820

NameCVE-2019-3820
DescriptionIt was discovered that the gnome-shell lock screen since version 3.15.91 did not properly restrict all contextual actions. An attacker with physical access to a locked workstation could invoke certain keyboard shortcuts, and potentially other actions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs921490

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnome-shell (PTS)jessie3.14.4-1~deb8u1fixed
stretch3.22.3-3vulnerable
buster3.30.2-11~deb10u1fixed
bullseye, sid3.34.1+git20191024-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnome-shellsource(unstable)3.30.2-3921490
gnome-shellsourcejessie(not affected)

Notes

[stretch] - gnome-shell <no-dsa> (Minor issue)
[jessie] - gnome-shell <not-affected> (Vulnerable code not present)
Introduced by: https://bugzilla.gnome.org/show_bug.cgi?id=745039
Introduced by: https://gitlab.gnome.org/GNOME/gnome-shell/commit/c79d24b60e773262091023feb6ee1b3deef1c471
Upstream issue: https://gitlab.gnome.org/GNOME/gnome-shell/issues/851

Search for package or bug name: Reporting problems