CVE-2019-3829

NameCVE-2019-3829
DescriptionA vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)jessie3.3.8-6+deb8u7fixed
jessie (security)3.3.30-0+deb8u1fixed
stretch3.5.8-5+deb9u4vulnerable
stretch (security)3.5.8-5+deb9u1vulnerable
buster3.6.7-4fixed
bullseye, sid3.6.10-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls28source(unstable)3.6.7-2
gnutls28sourceexperimental3.6.7-1
gnutls28sourcejessie(not affected)

Notes

[jessie] - gnutls28 <not-affected> (vulnerable code was introduced later)
https://bugzilla.redhat.com/show_bug.cgi?id=1677048
https://gitlab.com/gnutls/gnutls/issues/694
https://www.gnutls.org/security-new.html#GNUTLS-SA-2019-03-27
Upstream versions affected are from 3.5.8 and before 3.6.7.

Search for package or bug name: Reporting problems