CVE-2019-3832

NameCVE-2019-3832
DescriptionIt was discovered the fix for CVE-2018-19758 (libsndfile) was not complete and still allows a read beyond the limits of a buffer in wav_write_header() function in wav.c. A local attacker may use this flaw to make the application crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1712-1, DLA-2418-1
NVD severitylow
Debian Bugs922372

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)stretch1.0.27-3vulnerable
stretch (security)1.0.27-3+deb9u2fixed
buster1.0.28-6fixed
buster (security)1.0.28-6+deb10u1fixed
bookworm, sid, bullseye1.0.31-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesourcejessie1.0.25-9.1+deb8u4DLA-1712-1
libsndfilesourcestretch1.0.27-3+deb9u1DLA-2418-1
libsndfilesource(unstable)1.0.28-6922372

Notes

https://github.com/erikd/libsndfile/issues/456#issuecomment-463542436
https://github.com/erikd/libsndfile/pull/460
https://github.com/erikd/libsndfile/commit/6d7ce94c020cc720a6b28719d1a7879181790008

Search for package or bug name: Reporting problems