CVE-2019-3835

NameCVE-2019-3835
DescriptionIt was found that the superexec operator was available in the internal dictionary in ghostscript before 9.27. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1761-1, DSA-4432-1
NVD severitymedium (attack range: remote)
Debian Bugs925256

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.26a~dfsg-0+deb8u3fixed
stretch9.26a~dfsg-0+deb9u2fixed
stretch (security)9.26a~dfsg-0+deb9u3fixed
buster9.27~dfsg-1fixed
sid9.27~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.27~dfsg-1medium925256
ghostscriptsourceexperimental9.27~~dc1~dfsg-1medium
ghostscriptsourcejessie9.26a~dfsg-0+deb8u2mediumDLA-1761-1
ghostscriptsourcestretch9.26a~dfsg-0+deb9u2mediumDSA-4432-1

Notes

https://www.openwall.com/lists/oss-security/2019/03/21/1
https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=205591753126802da850ada6511a0ff8411aa287
https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=d683d1e6450d74619e6277efeebfc222d9a5cb91 (needed dependency)
https://bugs.ghostscript.com/show_bug.cgi?id=700585

Search for package or bug name: Reporting problems