DescriptionIt was discovered in gnutls before version 3.6.7 upstream that there is an uninitialized pointer access in gnutls versions 3.6.3 or later which can be triggered by certain post-handshake messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)stretch3.5.8-5+deb9u5fixed
stretch (security)3.5.8-5+deb9u1fixed
buster (security)3.6.7-4+deb10u4fixed
bullseye, sid3.7.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls28sourcejessie(not affected)
gnutls28sourcestretch(not affected)


[stretch] - gnutls28 <not-affected> (Vulnerable code introduced later in 3.6.4)
[jessie] - gnutls28 <not-affected> (vulnerable code was introduced later)
Upstream versions affected are 3.6.4 and later before 3.6.7

Search for package or bug name: Reporting problems