CVE-2019-3836

NameCVE-2019-3836
DescriptionIt was discovered in gnutls before version 3.6.7 upstream that there is an uninitialized pointer access in gnutls versions 3.6.3 or later which can be triggered by certain post-handshake messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)jessie3.3.8-6+deb8u7fixed
jessie (security)3.3.30-0+deb8u1fixed
stretch3.5.8-5+deb9u4vulnerable
stretch (security)3.5.8-5+deb9u1vulnerable
buster, sid3.6.7-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls28source(unstable)3.6.7-2medium
gnutls28sourceexperimental3.6.7-1medium
gnutls28sourcejessie(not affected)

Notes

[jessie] - gnutls28 <not-affected> (vulnerable code was introduced later)
https://bugzilla.redhat.com/show_bug.cgi?id=1678411
https://gitlab.com/gnutls/gnutls/issues/704
https://www.gnutls.org/security-new.html#GNUTLS-SA-2019-03-27
Upstream versions affected are 3.6.3 and later before 3.6.7

Search for package or bug name: Reporting problems