CVE-2019-3839

NameCVE-2019-3839
DescriptionIt was found that in ghostscript some privileged operators remained accessible from various places after the CVE-2019-6116 fix. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER. Ghostscript versions before 9.27 are vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1792-1, DSA-4442-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.26a~dfsg-0+deb8u6fixed
stretch9.26a~dfsg-0+deb9u4fixed
stretch (security)9.26a~dfsg-0+deb9u6fixed
buster9.27~dfsg-2+deb10u2fixed
buster (security)9.27~dfsg-2+deb10u3fixed
bullseye, sid9.50~dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.27~dfsg-1
ghostscriptsourcejessie9.26a~dfsg-0+deb8u3DLA-1792-1
ghostscriptsourcestretch9.26a~dfsg-0+deb9u3DSA-4442-1

Notes

http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=4ec9ca74bed49f2a82acb4bf430eae0d8b3b75c9
To prevent pdf2dsc regression additionally:
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=db24f253409d5d085c2760c814c3e1d3fa2dac59

Search for package or bug name: Reporting problems