CVE-2019-3840

NameCVE-2019-3840
DescriptionA NULL pointer dereference flaw was discovered in libvirt before version 5.0.0 in the way it gets interface information through the QEMU agent. An attacker in a guest VM can use this flaw to crash libvirtd and cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)jessie1.2.9-9+deb8u5fixed
jessie (security)1.2.9-9+deb8u7fixed
stretch3.0.0-4+deb9u3vulnerable
stretch (security)3.0.0-4+deb9u4vulnerable
bullseye, buster5.0.0-4fixed
sid5.0.0-4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsource(unstable)5.0.0-1low
libvirtsourcejessie(not affected)

Notes

[stretch] - libvirt <no-dsa> (Minor issue)
[jessie] - libvirt <not-affected> (vulnerable code was introduced in 1.2.14)
https://bugzilla.redhat.com/show_bug.cgi?id=1663051
https://www.redhat.com/archives/libvir-list/2019-January/msg00241.html
https://libvirt.org/git/?p=libvirt.git;a=commit;h=7cfd1fbb1332ae5df678b9f41a62156cb2e88c73

Search for package or bug name: Reporting problems