CVE-2019-3878

NameCVE-2019-3878
DescriptionA vulnerability was found in mod_auth_mellon before v0.14.2. If Apache is configured as a reverse proxy and mod_auth_mellon is configured to only let through authenticated users (with the require valid-user directive), adding special HTTP headers that are normally used to start the special SAML ECP (non-browser based) can be used to bypass authentication.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4414-1
NVD severitymedium (attack range: remote)
Debian Bugs925197

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache2-mod-auth-mellon (PTS)jessie0.9.1-1fixed
stretch0.12.0-2vulnerable
stretch (security)0.12.0-2+deb9u1fixed
buster, sid0.14.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache2-mod-auth-mellonsource(unstable)0.14.2-1medium925197
libapache2-mod-auth-mellonsourcejessie(not affected)
libapache2-mod-auth-mellonsourcestretch0.12.0-2+deb9u1mediumDSA-4414-1

Notes

[jessie] - libapache2-mod-auth-mellon <not-affected> (Vulnerable code not present)
https://bugzilla.redhat.com/show_bug.cgi?id=1576719
https://github.com/Uninett/mod_auth_mellon/pull/196
https://github.com/Uninett/mod_auth_mellon/commit/e09a28a30e13e5c22b481010f26b4a7743a09280

Search for package or bug name: Reporting problems