CVE-2019-3885

NameCVE-2019-3885
DescriptionA use-after-free flaw was found in pacemaker up to and including version 2.0.1 which could result in certain sensitive information to be leaked via the system logs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs927714

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pacemaker (PTS)stretch1.1.16-1fixed
bullseye, sid, buster2.0.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pacemakersource(unstable)2.0.1-3medium927714
pacemakersourcestretch(not affected)

Notes

[stretch] - pacemaker <not-affected> (Vulnerable code introduced later)
https://www.openwall.com/lists/oss-security/2019/04/17/1
https://github.com/ClusterLabs/pacemaker/pull/1749 (master)
https://github.com/ClusterLabs/pacemaker/pull/1750 (1.1)
https://lists.clusterlabs.org/pipermail/users/2019-May/025822.html

Search for package or bug name: Reporting problems