DescriptionAn exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV, before version 4.2.0. A specially crafted JSON file can cause a buffer overflow, resulting in multiple heap corruptions and potentially code execution. An attacker can provide a specially crafted file to trigger this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs948180

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opencv (PTS)buster3.2.0+dfsg-6fixed
trixie, sid4.6.0+dfsg-13.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opencvsourcejessie(not affected)
opencvsourcestretch(not affected)
opencvsourcebuster(not affected)


[buster] - opencv <not-affected> (Vulnerable code introduced later)
[stretch] - opencv <not-affected> (Vulnerable code introduced later)
[jessie] - opencv <not-affected> (The vulnerable code was introduced later)
Fixed by: (4.2.0)
Persistence implementation refactored in:

Search for package or bug name: Reporting problems