CVE-2019-5064

NameCVE-2019-5064
DescriptionAn exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV, before version 4.2.0. A specially crafted JSON file can cause a buffer overflow, resulting in multiple heap corruptions and potentially code execution. An attacker can provide a specially crafted file to trigger this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs948180

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opencv (PTS)jessie2.4.9.1+dfsg-1+deb8u1fixed
jessie (security)2.4.9.1+dfsg-1+deb8u2fixed
stretch2.4.9.1+dfsg1-2fixed
buster3.2.0+dfsg-6fixed
bullseye4.2.0+dfsg-5vulnerable
sid4.2.0+dfsg-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opencvsource(unstable)(unfixed)948180
opencvsourcebuster(not affected)
opencvsourceexperimental4.2.0+dfsg-1
opencvsourcejessie(not affected)
opencvsourcestretch(not affected)

Notes

[buster] - opencv <not-affected> (Vulnerable code introduced later)
[stretch] - opencv <not-affected> (Vulnerable code introduced later)
[jessie] - opencv <not-affected> (The vulnerable code was introduced later)
https://talosintelligence.com/vulnerability_reports/TALOS-2019-0853
Fixed by: https://github.com/opencv/opencv/commit/f42d5399aac80d371b17d689851406669c9b9111 (4.2.0)
https://github.com/opencv/opencv/issues/15857
Persistence implementation refactored in: https://github.com/opencv/opencv/pull/13011

Search for package or bug name: Reporting problems