CVE-2019-5420

NameCVE-2019-5420
DescriptionA remote code execution vulnerability in development mode Rails <5.2.2.1, <6.0.0.beta3 can allow an attacker to guess the automatically generated development mode secret token. This secret token can be used in combination with other Rails internals to escalate to a remote code execution exploit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs924521

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)jessie2:4.1.8-1+deb8u4fixed
jessie (security)2:4.1.8-1+deb8u5fixed
stretch2:4.2.7.1-1+deb9u1fixed
buster2:5.2.2.1+dfsg-1fixed
bullseye, sid2:5.2.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2:5.2.2.1+dfsg-1924521
railssourcejessie(not affected)
railssourcestretch(not affected)

Notes

[stretch] - rails <not-affected> (Vulnerable code not present)
[jessie] - rails <not-affected> (vulnerable code is not present in 4.x)
https://www.openwall.com/lists/oss-security/2019/03/13/3
Introduced in https://github.com/rails/rails/commit/69f976b859cae7f9d050152103da018b7f5dda6d

Search for package or bug name: Reporting problems