CVE-2019-5436

NameCVE-2019-5436
DescriptionA heap buffer overflow in the TFTP receiving code allows for DoS or arbitrary code execution in libcurl versions 7.19.4 through 7.64.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1804-1
NVD severitymedium (attack range: local)
Debian Bugs929351

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u11vulnerable
jessie (security)7.38.0-4+deb8u15fixed
stretch (security), stretch7.52.1-5+deb9u9vulnerable
buster, sid7.64.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.64.0-4medium929351
curlsourcejessie7.38.0-4+deb8u15mediumDLA-1804-1

Notes

https://curl.haxx.se/docs/CVE-2019-5436.html
Introduced by: https://github.com/curl/curl/commit/0516ce7786e95
Fixed by: https://github.com/curl/curl/commit/2576003415625d7b5f0e390902f8097830b82275

Search for package or bug name: Reporting problems